Ruby 2.4の公式サポート終了について

本書で使用しているRubyのバージョンは2.4ですが、Ruby 2.4の公式サポートは2020年3月31日に終了しました。

Ruby 2.4 公式サポート終了

ただし、学習目的であればRuby 2.4を使っても問題ありません。また、Ruby 2.5以上のバージョンで学習するのもOKです。

詳しい説明は以下のページをご覧ください。

Q. チェリー本の学習時にサポートが切れたRuby 2.4を使ってもいいの? - give IT a try